Коммутаторы Ethernet. Начальные сведения

  • Введение
  • Что такое коммутатор Ethernet?
    • Основы
    • Атрибуты коммутаторов Ethernet
  • Сравнение сетевых устройств
  • Классы коммутаторов Ethernet
    • Коммутаторы для рабочих групп
    • Магистральные коммутаторы
    • Преимущества коммутаторов Ethernet
  • Применение коммутаторов
    • Объединение концентраторов 10Base-T с помощью магистрального коммутатора
    • Выделенная полоса для каждого пользователя
    • Рабочие группы с несколькими серверами
    • Объединение коммутаторов рабочих групп и корпоративных серверов
    • Заключение


Что такое коммутатор Ethernet?

Основы

Коммутатор Ethernet представляет собой устройство для организации сетей большого размера. Для того, чтобы лучше разобраться в устройстве и работе коммутаторов Ethernet, полезно понять основы технологии организации кабельных систем сети.

Повторители

В начале 80-х годов сети Ethernet организовывались на базе шинной топологии с использованием сегментов на основе коаксиального кабеля длиной до 500 метров. Увеличение размеров сетей поставило задачу преодоления 500-метрового барьера. Для решения этой задачи использовались повторители (repeater):

Повторитель просто копирует (пересылает) все пакеты Ethernet из одного сегмента во все другие, подключенные к нему. Основной задачей повторителя является восстановление электрических сигналов для передачи их в другие сегменты. За счет усиления и восстановления формы электрических сигналов повторителем становится возможным расширение сетей, построенных на основе коаксиального кабеля и увеличение общего числа пользователей сети

Мосты и маршрутизаторы

При использовании повторителей максимальная протяженность сети составляет 2500 метров. Для преодоления этого ограничения требуются другие устройства, называемые мостами (bridge). Мосты имеют много отличий от повторителей. Повторители передают все пакеты, а мосты только те, которые нужно. Если пакет не нужно передавать в другой сегмент, он фильтруется. Для мостов существуют многочисленные алгоритмы (правила) передачи и фильтрации пакетов минимальным требованием является фильтрация пакетов по адресу получателя.

Другим важным отличием мостов от повторителей является то, что сегменты, подключенные к повторителю образуют одну разделяемую среду, а сегменты, подключенные к каждому порту моста образуют свою среду с полосой 10 Mbps. При использовании моста пользователи одного сегмента разделяют полосу, а пользователи разных сегментов используют независимые Среды. Следовательно, мост обеспечивает преимущества как с точки зрения расширения сети, так и обеспечения большей полосы для каждого пользователя.

Поначалу в сетях Ethernet использовалась шинная топология на основе коаксиального кабеля, а для расширения сетей применялись 2-х портовые повторители или мосты. Однако, в конце 80-х годов началось широкое распространение сетей на основе кабеля со скрученными парами проводников (витая пара). Новая технология 10Base-T стала очень популярной и привела к трансформации топологии сетей от шинной магистрали к организации соединений типа "звезда". Требования к повторителям и мостам для таких сетей существенно изменились по сравнению с простыми двухпортовыми устройствами для сетей с шинной топологией - современные мосты и повторители представляют собой сложные многопортовые устройства. Мосты позволяют сегментировать сети на меньшие части, в которых общую среду разделяет небольшое число пользователей.

Маршрутизаторы, подобно мостам, также позволяют сегментировать сети Ethernet. маршрутизаторы фильтруют и пересылают сетевой трафик на основе алгоритмов и правил, существенно отличающихся от тех, что используются мостами. Такой способ сегментирования сетей более дорог многопортовые мосты и маршрутизаторы обычно стоят около $1,000 за порт.

Переключение портов

Сегодняшние модульные концентраторы (повторители) часто позволяют организовать несколько сегментов, каждый из которых предоставляет пользователям отдельную разделяемую полосу 10 Mbps. Некоторые концентраторы позволяют программным путем разделять порты устройства на независимые сегменты такая возможность называется переключением портов. Концентратор, к примеру, может содержать три различных сегмента Ethernet, организуемые внутренними средствами хаба. Переключение портов обеспечивает администратору сети высокую гибкость организации сегментов, позволяя переносить порты из одного сегмента в другой программными средствами. Эта возможность особенно полезна для распределения нагрузки между сегментами Ethernet и снижения расходов, связанных с подобными операциями. Переключение портов статическое связывание портов с различными сегментами Ethernet - сильно отличается от описанной ниже коммутации Ethernet.

Атрибуты коммутаторов Ethernet

Коммутаторы Ethernet подобно мостам и маршрутизаторам способны сегментировать сети Ethernet. Как и многопортовые мосты коммутаторы передают пакеты между портами на основе адреса получателя, включенного в каждый пакет. реализация коммутаторов обычно отличается от мостов в части возможности организации одновременных соединений между любыми парами портов устройства - это значительно расширяет суммарную пропускную способность сети. Более того, мосты в соответствии со стандартом IEEE 802.1d должны получить пакет целиком до того, как он будет передан адресату, а коммутаторы могут начать передачу пакета, не приняв его полностью.

Виртуальные соединения

Коммутатор Ethernet поддерживает внутреннюю таблицу, связывающую порты с адресами подключенных к ним устройств (таблица 1). Эту таблицу администратор сети может создать самостоятельно или задать ее автоматическое создание средствами коммутатора.

Таблица 1

MAC-адрес | Номер порта
A | 1
B | 2
C | 3
D | 4

Используя таблицу адресов и содержащийся в пакете адрес получателя, коммутатор организует виртуальное соединение порта отправителя с портом получателя и передает пакет через это соединение. На рисунке 4 узел А посылает пакет узлу D. Найдя адрес получателя в своей внутренней таблице, коммутатор передает пакет в порт 4.

Рисунок 4

Виртуальное соединение между портами коммутатора сохраняется в течение передачи одного пакета, т.е. для каждого пакета виртуальное соединение организуется заново на основе содержащегося в этом пакете адреса получателя.

Поскольку пакет передается только в тот порт, к которому подключен адресат, остальные пользователи (в нашем примере - B и C) не получат этот пакет. Таким образом, коммутаторы обеспечивают средства безопасности, недоступные для стандартных повторителей Ethernet (см. раздел "Сравнение сетевых устройств").

Одновременные соединения

В коммутаторах Ethernet передача данных между любыми парами портов происходит независимо и, следовательно, для каждого виртуального соединения выделяется вся полоса канала. Например, коммутатор 10 Mbps на рисунке 5 обеспечивает одновременную передачу пакета из A в D и из порта B в порт C с полосой 10 Mbps для каждого соединения.

Рисунок 5

Поскольку для каждого соединения предоставляется полоса Mbps, суммарная пропускная способность коммутатора в приведенном примере составляет 20 Mbps. Если данные передаются между большим числом пар портов, интегральная полоса соответственно расширяется. Например, 24 портовый коммутатор Ethernet может обеспечивать интегральную пропускную способность до 120 Mbps при одновременной организации 12 соединений с полосой 10 Mbps для каждого из них. теоретически, интегральная полоса коммутатора растет пропорционально числу портов. Однако, в реальности скорость пересылки пакетов, измеренная в Mbps, меньше чем суммарная полоса пар портов за счет так называемой внутренней блокировки. Для коммутаторов высокого класса блокировка весьма незначительно снижает интегральную полосу устройства.

Коммутатор Ethernet 10 Mbps может обеспечить высокую пропускную способность при условии организации одновременных соединений между всеми парами портов. Однако, в реальной жизни трафик обычно представляет собой ситуацию "один ко многим" (например, множество пользователей сети обращается к ресурсам одного сервера). В таких случаях пропускная способность коммутатора в нашем примере не будет превышать 10 Mbps, и коммутатор не обеспечит существенного преимущества по сравнению с обычным концентратором (повторителем).

Рисунок 6

На рисунке 6 три узла A, B и D передают данные узлу C. Коммутатор сохраняет пакеты от узлов A и B в своей памяти до тех пор, пока не завершится передача пакета из узла D. После завершения передачи пакета коммутатор начинает передавать хранящиеся в памяти пакеты от узлов A и B. В данном случае пропускная способность коммутатора определяется полосой канала C (в данном случае 10 Mbps). Описанная в данном примере ситуация является другой формой блокировки.

Производительность коммутатора

Другим важным параметром коммутатора является его производительность. Для того, чтобы охарактеризовать ее используются несколько параметров:

  1. скорость передачи между портами
  2. общая пропускная способность
  3. задержка

Скорость передачи между портами

При полосе 10 Mbps Ethernet может передавать 14880 пакетов в секунду (PPS) для пакетов минимального размера (64 байта). Этот параметр определяется свойствами среды. Коммутатор, который способен обеспечить скорость 14880 PPS между портами, полностью использует возможности среды. Полоса пропускания среды является важным параметром, поскольку коммутатор, обеспечивающий передачу пакетов с такой скоростью, полностью использует возможности среды, предоставляя пользователям максимальную полосу.

Общая пропускная способность

Измеренная в Mbps или PPS, общая пропускная способность характеризует максимальную скорость, с которой пакеты могут передаваться через коммутатор адресатам. В коммутаторах, все порты которых имеют полосу 10 Mbps суммарная пропускная способность равна скорости порта, умноженной на число виртуальных соединений, которые могут существовать одновременно (число портов коммутатора, поделенное на 2). Коммутатор, способный обеспечивать максимальную скорость передачи не имеет внутренней блокировки.

Задержка

Задержка - это промежуток времени между получением пакета от отправителя и передачей его получателю. Обычно задержку измеряют относительно первого бита пакета.

Коммутаторы Ethernet могут обеспечивать очень низкую задержку после того, как будет определен адресат. Поскольку адрес получателя размещается в начале пакета, передачу можно начать до того, как пакет будет полностью принят от отправителя. Такой метод называется коммутацией на лету (cut-through) и обеспечивает минимальную задержку. Малая задержка важна, поскольку с ней непосредственно связана производительность коммутатора. Однако метод коммутации на лету не проверяет пакеты на предмет ошибок.

При таком способе коммутатор передает все пакеты (даже те, которые содержат ошибки). Например, при возникновении коллизии после начала передачи пакета (адрес уже получен) полученный фрагмент все равно будет передан адресату. Передача таких фрагментов занимает часть полосы канала и снижает общую производительность коммутатора.

При передаче пакетов из низкоскоростного порта в высокоскоростной (например, из порта 10 Mbps в порт 100 Mbps) коммутацию на лету использовать вообще невозможно. Поскольку порт-приемник имеет большую скорость, нежели передатчик, при использовании коммутации на лету неизбежно возникнут ошибки. При организации виртуального соединения между портами с разной скоростью требуется буферизация пакетов.

Малая задержка повышает производительность сетей, в которых данные передаются в виде последовательности отдельных пакетов, каждый из которых содержит адрес получателя. В сетях, где данные передаются в форме последовательности пакетов с организацией виртуального канала, малая задержка меньше влияет на производительность.


Коммутаторы Ethernet. Сравнение сетевых устройств

Сравнение сетевых устройств

Повторители

Повторители Ethernet, контексте сетей 10Base-T часто называемые концентраторами или хабами, работают в соответствии со стандартом IEEE 802.3. Повторитель просто передает полученные пакеты во все свои порты независимо от адресата.

Хотя все устройства, подключенные к повторителю Ethernet (включая другие повторители) "видят" весь сетевой трафик, получить пакет должен только тот узел, которому он адресован. Все остальные узлы должны игнорировать этот пакет. некоторые сетевые устройства (например, анализаторы протоколов) работают на основе того, что сетевая среда (типа Ethernet) является общедоступной и анализируют весь сетевой трафик. Для некоторых сред, однако, способность каждого узла видеть все пакеты неприемлема по соображениям безопасности.

С точки зрения производительности повторители просто передают пакеты с использованием всей полосы канала. Задержка, вносимая повторителем весьма мала (в соответствии с IEEE 802.3 - менее 3 микросекунд). Сети, содержащие повторители имеют полосу 10 Mbps подобно сегменту на основе коаксиального кабеля и прозрачны для большинства сетевых протоколов, таких как TCP/IP и IPX.

Мосты

Мосты функционируют в соответствии со стандартом IEEE 802.1d. Подобно коммутаторам Ethernet мосты не зависят от протокола и передают пакеты порту, к которому подключен адресат. Однако, в отличие от большинства коммутаторов Ethernet, мосты не передают фрагменты пакетов при возникновении коллизий и пакеты с ошибками, поскольку все пакеты буферизуются перед их пересылкой в порт адресата. Буферизация пакетов (store-and-forward) приводит к возникновению задержки по сравнению с коммутацией на лету. Мосты могут обеспечивать производительность, равную пропускной способности среды, однако внутренняя блокировка несколько снижает скорость их работы.

Маршрутизаторы

Работа маршрутизаторов зависит от сетевых протоколов и определяется связанной с протоколом информацией, передаваемой в пакете. Подобно мостам, маршрутизаторы не передают адресату фрагменты пакетов при возникновении коллизий. Маршрутизаторы сохраняют пакет целиком в своей памяти прежде, чем передать его адресату, следовательно, при использовании маршрутизаторов пакеты передаются с задержкой. Маршрутизаторы могут обеспечивать полосу, равную пропускной способности канала, однако для них характерно наличие внутренней блокировки. В отличие от повторителей, мостов и коммутаторов маршрутизаторы изменяют все передаваемые пакеты.

Резюме

Основные различия между сетевыми устройствами показаны в таблице 2.

Таблица 2.

Характеристика | Повторитель Ethernet | Коммутатор Ethernet | Мост | Маршрутизатор
Стоимость порта | $75 - $200 | $250 - $2000 | $1000 - $3000 | $1000 - $5000
Скорость передачи между портами | Скорость среды во всех случаях | До скорости передачи среды | До скорости передачи среды | До скорости передачи среды
Суммарная полоса | 10 Мбит/сек | Высокая | Высокая | Высокая
Задержка при передаче между портами Ethernet | < 3 мксек (коммутация на лету) | < 40 мксек (для устройств с буферизацией зависит от размера пакета) | 50 - 1500 мксек | 50 - 1500 мксек (в зависимости от протокола задержка может возрастать)
Решение о передаче на основе аппаратных адресов | - | + | + | -
Независимость от протокола | + | + | + | -
Изменение пакетов Ethernet | - | - | - | +
Стандарт IEEE | 802.3 |  | 802.1 |


Классы коммутаторов Ethernet

Хотя все коммутаторы имеют много общего, целесообразно разделить их на два класса, предназначенных для решения разных задач.

Коммутаторы для рабочих групп

Коммутаторы для рабочих групп обеспечивают выделенную полосу при соединении любой пары узлов, подключенных к портам коммутатора. Если порты имеют одинаковую скорость, получатель пакета должен быть свободен, чтобы не возникло блокировки.

Поддерживая на каждый порт по крайней мере то число адресов, которые могут присутствовать в сегменте, коммутатор обеспечивает для каждого порта выделенную полосу 10 Mbps. Каждый порт коммутатора связан с уникальным адресом подключенного к данному порту устройства Ethernet.

Рисунок 7

Физическое соединение "точка-точка" между коммутаторами рабочих групп и узлами 10Base-T обычно выполняется неэкранированным кабелем на основе скрученных пар, а в узлах сети устанавливается оборудование, соответствующее стандарту 10Base-T.

Коммутаторы рабочих групп могут работать со скоростью 10 или 100 Mbps для различных портов. Такая возможность снижает уровень блокировки при попытке организации нескольких соединений клиентов 10 Mbps с одним скоростным портом. В рабочих группах с архитектурой клиент-сервер несколько клиентов 10 Mbps могут обращаться к серверу, подключенному к порту 100 Mbps. В показанном на рисунке 8 примере три узла 10 Mbps одновременно обращаются к серверу через порт 100 Mbps. Из полосы 100 Mbps, доступной для доступа к серверу, используется 30 Mbps, а 70 Mbps доступно для одновременного подключения к серверу еще семи устройств 10 Mbps через виртуальные каналы.

Рисунок 8

Поддержка различных скоростей полезна также для объединения групповых коммутаторов Ethernet с использованием концентраторов 100 Mbps Fast Ethernet (100Base-T) в качестве локальных магистралей (local backbone). В показанной на рисунке 9 конфигурации коммутаторы, поддерживающие скорости 10 Mbps и 100 Mbps подключены к концентратору 100 Mbps. Локальный трафик остается в пределах рабочей группы, а остальной трафик передается в сеть через концентратор 100 Mbps Ethernet.

Рисунок 9

Для подключения к повторителю 10 или 100 Mbps коммутатор должен иметь порт, способный работать с большим числом адресов Ethernet.

Основным преимуществом коммутаторов для рабочих групп является высокая производительность сети на уровне рабочей группы за счет предоставления каждому пользователю выделенной полосы канала (10 Mbps). Кроме того, коммутаторы снижают (в пределе до нуля) количество коллизий - в отличие от магистральных коммутаторов, описанных ниже, коммутаторы рабочих групп, не будут передавать коллизионные фрагменты адресатам. Коммутаторы для рабочих групп позволяют полностью сохранить сетевую инфраструктуру со стороны клиентов, включая программы, сетевые адаптеры, кабели. Стоимость коммутаторов для рабочих групп в расчете на один порт сегодня сравнима с ценами портов управляемых концентраторов.

Магистральные коммутаторы

Магистральные коммутаторы обеспечивают соединение со скоростью передачи среды между парой незанятых сегментов Ethernet. Если скорость портов для отправителя и получателя совпадают, сегмент получателя должен быть свободен во избежание блокировки.

Рисунок 10

На уровне рабочей группы каждый узел разделяет полосу 10 Mbps с другими узлами в том же сегменте. Пакет, адресованный за пределы данной группы, будет передан магистральным коммутатором как показано на рисунке 10. Магистральный коммутатор обеспечивает одновременную передачу пакетов со скоростью среды между любыми парами своих портов. Подобно коммутаторам для рабочих групп, магистральные коммутаторы могут поддерживать различную скорость для своих портов. Магистральные коммутаторы могут работать с сегментами 10Base-T и сегментами на основе коаксиального кабеля. В большинстве случаев использование магистральных коммутаторов обеспечивает более простой и эффективный способ повышения производительности сети по сравнению с маршрутизаторами и мостами.

Рисунок 11

Основным недостатком при работе с магистральными коммутаторами является то, что на уровне рабочих групп пользователи работают с разделяемой средой, если они подключены к сегментам, организованным на основе повторителей или коаксиального кабеля. Более того, время отклика на уровне рабочей группы может быть достаточно большим. В отличие от узлов, подключенных к портам коммутатора, для узлов, находящихся в сегментах 10Base-T или сегментах на основе коаксиального кабеля полоса 10 Mbps не гарантируется и они зачастую вынуждены ждать, пока другие узлы не закончат передачу своих пакетов. На уровне рабочей группы по прежнему сохраняются коллизии, а фрагменты пакетов с ошибками будут пересылаться во все сети, подключенные к магистрали. Перечисленных недостатков можно избежать, если на уровне рабочих групп использовать коммутаторы взамен хабов 10Base-T. В большинстве ресурсоемких приложений коммутатор 100 Mbps может выполнять роль скоростной магистрали для коммутаторов рабочих групп с портами 10 и 100 Mbps, концентраторами 100 Mbps и серверами, в которых установлены адаптеры Ethernet 100 Mbps.

Сравнение возможностей

Основные свойства коммутаторов Ethernet приведены в таблице 3:

Таблица 3

Характеристика | Коммутатор для рабочей группы | Магистральный коммутатор
Число узлов на порт | 1 | > 1
Выделенная полоса для отдельного узла | + | -
Установка и конфигурирование | Простое | Средней сложности
Совместимость с существующими адаптерами, кабелями и программами | + | +
Соединение сегментов на основе коаксиального кабеля и витой пары | - | +
Отсутствие коллизий на уровне рабочей группы | + | -
При коммутации с буферизацией коллизии не передаются в другие сегменты | + | -
Безопасность | Высокий уровень | Средний уровень
Поддержка различных скоростей | Доступна | Доступна
Основные применения | Повышение производительности рабочих групп 10Base-T | Альтернатива мостам и маршрутизаторам для сегментирования сетей. Соединение коммутаторов рабочих групп.

Преимущества коммутаторов Ethernet

Ниже перечислены основные преимущества использования коммутаторов Ethernet:

  1. Повышение производительности за счет высокоскоростных соединений между сегментами Ethernet (магистральные коммутаторы) или узлами сети (коммутаторы для рабочих групп). В отличие от разделяемой среды Ethernet коммутаторы позволяют обеспечить рост интегральной производительности при добавлении в сеть пользователей или сегментов.
  2. Снижение числа коллизий, особенно в тех случаях, когда каждый пользователь подключен к отдельному порту коммутатора.
  3. Незначительные расходы при переходе от разделяемой среды к коммутируемой за счет сохранения существующей инфраструктуры 10 Mbps Ethernet (кабели, адаптеры, программы).
  4. Повышение безопасности за счет передачи пакетов только в тот порт, к которому подключен адресат.
  5. Малое и предсказуемое время задержки за счет того, что полосу разделяет небольшое число пользователей (в идеале - один)


Коммутаторы Ethernet. Применение коммутаторов

Применение коммутаторов

Объединение концентраторов 10Base-T с помощью магистрального коммутатора

Магистральные коммутаторы прежде всего используются в качестве недорогой альтернативы многопротокольным маршрутизаторам для сегментирования сети. Например, при добавление в сеть, уже содержащую 100 узлов, некоторого количества производительных станций, работа этих станций в сети будет казаться замедленной. Выходом из положения может быть деление сети на несколько сегментов с использование магистрального коммутатора для связи этих сегментов.

Рисунок 12

В приведенном на рисунке 12 примере интегральная пропускная способность составляет 40 Mbps (четыре сегмента 10 Mbps Ethernet). В такой ситуации можно использовать для сегментирования и мультипротокольный маршрутизатор, однако это будет дороже и сложнее. Если основной задачей является повышение производительности сети, установка коммутатора обеспечит наиболее простое и эффективное решение.

Выделенная полоса для каждого пользователя

Магистральные коммутаторы обеспечивают эффективное сегментирование сети, а коммутаторы для рабочих групп способны предоставить каждому пользователю всю полосу среды. Следовательно, коммутаторы для рабочих групп позволяют значительно повысить производительность работы каждого пользователя в группе и избавить от коллизий. Повышение производительности и снижение времени отклика обеспечивают гигантские преимущества по сравнению с использованием разделяемой среды.

Рисунок 13

Рабочие группы с несколькими серверами

Если все узлы подключены к концентратору 10Base-T производительность будет невысокой за счет частых случаев одновременного обращения нескольких пользователей к одному серверу. Замена хаба 10Base-T коммутатором для рабочей группы может существенно повысить производительность работы группы.

Рабочие группы с архитектурой клиент-сервер

Для рабочих групп, где большая часть трафика связана с одним узлом (сервер) существенно повысить производительность можно за счет использования коммутатора, имеющего порты, работающие с более высокой скоростью, нежели скорость клиентов В таком случае сервер подключается к порту 100 Mbps, что позволяет избавиться от пробок при одновременном обращении к серверу нескольких пользователей (см. рисунок 8). Используя порт 100 Mbps для подключения сервера, можно обеспечить десять одновременных подключений со скоростью 10 Mbps. Порт 100 Mbps можно также использовать для подключения к магистральному коммутатору или концентратору 100 Mbps.

Объединение коммутаторов рабочих групп и корпоративных серверов

Создание больших сетей Ethernet на базе коммутаторов для рабочих групп требует организации скоростного соединения коммутаторов между собой. Кроме того, целесообразно организовать скоростную магистраль для доступа к серверам, используемым всеми рабочими группами сети. Для организации такой магистрали можно использовать коммутаторы или хабы 100 Mbps Ethernet, к портам которых подключаются коммутаторы рабочих групп как это показано на рисунке 14.

Рисунок 14

В нашем примере рабочие станции имеют выделенную полосу 10 Mbps для доступа к серверам через коммутатор рабочей группы и концентратор 100 Mbps Ethernet. Концентратор 100Base-T и корпоративные серверы обычно располагаются в одном помещении, а коммутаторы рабочих групп устанавливаются вблизи этих групп и соединяются с хабом стандартными кабелями.

Заключение

Коммутация Ethernet является недорогой высокопроизводительной технологией модернизации существующих сетей 10 Mbps Ethernet. Коммутатор является достойной альтернативой многопротокольным маршрутизаторам для деление больших сетей на несколько сегментов. Коммутаторы для рабочих групп предоставляют выделенную полосу каждому пользователю и, по сути, являются единственным эффективным способом модернизации сетей 10Base-T. Стоимость таких коммутаторов в расчете на один порт сегодня сравнима с ценой порта в сегментируемом наращиваемом концентраторе. При использовании вместе с магистралями 100 Mbps коммутаторы для рабочих групп позволяют организовать большие высокопроизводительные сети. Для организации эффективных магистралей 100 Mbps следует использовать коммутаторы 100 Mbps Ethernet, известные также как Fast Ethernet и 100Base-T. Коммутаторы можно использовать без внесения каких-либо изменений в существующие кабельные системы 10Base-T, оборудование рабочих станций и т.п., что позволяет значительно снизить расходы на модернизацию сетей.


Коммутаторы Ethernet. Введение

Введение

Разработанный в 1973 стандарт Ethernet сегодня является наиболее популярным среди стандартов ЛВС. Как технология с разделяемой средой Ethernet обеспечивает скорость передачи 10 мегабит в секунду (Mbps) для всех пользователей, имеющих доступ к среде передачи и протокол разрешения доступа.

По мере расширения сети доступная пользователю полоса (средняя скорость передачи) сужается за счет того, что канал 10 Mbps делится между всеми узлами сети. Повышение производительности компьютеров и использование приложений с интенсивным сетевым трафиком требует расширения полосы для полной реализации возможностей программ и оборудования. Расширение сетей и повышение производительности компьютеров требуют расширения доступной пользователям полосы, обеспечиваемой сетевой средой передачи.

Существует два способа расширения полосы, доступной каждому пользователю. Технология Fast Ethernet базируется на расширении полосы разделяемой среды до 100 Mbps, обеспечивая рост скорости в 10 раз. Другим способ является снижение числа узлов сети, имеющих доступ к разделяемой среде и, следовательно, расширение доступной оставшимся узлам полосы. В предельном случае вся полоса канала передачи может быть предоставлена одному пользователю.

Процесс снижения числа узлов в сети называется сегментацией и осуществляется за счет деления большой сети на несколько меньших. Поскольку пользователям может требоваться доступ к ресурсам других сегментов, нужен механизм обеспечения такого доступа, обеспечивающий межсегментный обмен с достаточно высокой скоростью. Новый тип устройств, называемых коммутаторами Ethernet, обеспечивает требуемые возможности. В данной статье рассматриваются различные типы коммутаторов Ethernet и их роль в повышении производительности сетей Ethernet.